Welcome

M9036A PXI Embedded Controller

LabVIEWÔ G Trigger Driver

LabVIEWÔ G Programming Information

This help file contains LabVIEW G reference information for the Agilent M9036A PXI Embedded Controller Trigger Driver. The driver was preinstalled at the factory.

The Agilent LabVIEW G driver version 1.0.x or later is required for LabVIEW programmatic control of the M9036A trigger subsystem.

Using LabVIEW

National Instrument's LabVIEW is not preinstalled on the M9036 controller, only the trigger driver is preinstalled. Consequently, the LabVIEW trigger driver and help files exist only in either the:

Program Files\Agilent\M9036\LabVIEW Driver\8.x or \20xx folder or the

Program Files (x86)\Agilent\M9036\LabVIEW Driver\8.x or \20xx folder.

(8.x represents LabVIEW version 8.5) and 20xx represents LabVIEW 2009, 2010, etc.).

Open the appropriate folder (8.x or 20xx) for the version of LabVIEW you installed on the M9036A. Copy the folder named Agilent M9036 (this contains three subfolders and other files) and paste it in the directory:

Program Files\National Instruments\LabVIEW <your version>\instr.lib or

Program Files (x86)\National Instruments\LabVIEW <your version>\instr.lib

You also need to copy the associated LabVIEW help file, AgM9036_LabVIEW_Help.chm from the

Program Files\Agilent\M9036\LabVIEW Driver Help folder or the

Program Files (x86)\Agilent\M9036\LabVIEW Driver Help folder

to the directory:

Program Files\National Instruments\LabVIEW <your version> \help or

Program Files (x86)\National Instruments\LabVIEW <your version> \help

See Also:

Introduction to AgM9036 LabVIEW Driver
  • System Requirements
Programming Reference
Programming Examples
Related Documentation

© 2011 Agilent Technologies, Inc.

Version 1.0
LabView is a registered trademark of National Instruments


Introduction to AgM9036 LabVIEW Driver

The AgM9036A LabVIEW Trigger Driver provides programmatic control for the Agilent M9036A PXIe Embedded Controller trigger route subsystem.

The M9036A Startup Guide and User Guide provide additional detailed information on the trigger subsystem. Theses guides are available on the M9036A Product Information CD supplied with your controller or on the web: www.agilent.com\find\M9036A.

The Agilent LabVIEW G driver version 1.0.x or later is required for LabVIEW programmatic control of the M9036A trigger subsystem.

Using LabVIEW

National Instrument's LabVIEW is not preinstalled on the M9036 controller, only the trigger driver is preinstalled. Consequently, the LabVIEW trigger driver and help files exist only in either the:

Program Files\Agilent\M9036\LabVIEW Driver\8.x or \20xx folder or the

Program Files (x86)\Agilent\M9036\LabVIEW Driver\8.x or \20xx folder.

(8.x represents LabVIEW version 8.5) and 20xx represents LabVIEW 2009, 2010, etc.).

Open the appropriate folder (8.x or 20xx) for the version of LabVIEW you installed on the M9036A. Copy the folder named Agilent M9036 (this contains three subfolders and other files) and paste it in the directory:

Program Files\National Instruments\LabVIEW <your version>\instr.lib or

Program Files (x86)\National Instruments\LabVIEW <your version>\instr.lib

You also need to copy the associated LabVIEW help file, AgM9036_LabVIEW_Help.chm from the

Program Files\Agilent\M9036\LabVIEW Driver Help folder or the

Program Files (x86)\Agilent\M9036\LabVIEW Driver Help folder

to the directory:

Program Files\National Instruments\LabVIEW <your version> \help or

Program Files (x86)\National Instruments\LabVIEW <your version> \help

Overview

The front panel PXI trigger connector is an external (front panel) SMB connector and is used to route an external trigger signal to or from the PXI backplane or from a software-generated trigger. Trigger signals are TTL compatible and edge sensitive. This LabVIEW driver allows you to configure the trigger routing within the Agilent M9036A.

The M9036A provides the following four trigger routing possibilities:

  • From the front panel PXI trigger connector to a specified PXI backplane trigger bus line.
  • From a selected PXI backplane trigger bus line to the front panel PXI trigger connector.
  • From a software-generated trigger to a specified PXI backplane trigger bus line.
  • From a software-generated trigger to the front panel SMB connector via a specified PXI backplane trigger bus line.

Trigger routes other than the four described above are invalid. For example, you cannot route a trigger from one backplane trigger bus line to another backplane trigger bus line. Similarly, you cannot route a trigger sourced by the front panel SMB connector back to itself.

A “software trigger” does not generate a trigger pulse. The Trigger Routing Set Software Route Trigger State property in the driver defines a voltage level: True = 3.3V (asserted) and False = 0.0V (not asserted). To generate a pulse, you must toggle the state of the Trigger Routing Set Software Route Trigger State property; that is, set the property to one state, wait for the desired length of pulse, and then setting the property to the opposite state.

Trigger IO functions

All trigger modes are programmable through the factory-installed trigger driver (AgM9036).

The default trigger route (the path established at power on or at Reset) has no internal connection to the front panel SMB connector and no connection to any of the PXI backplane trigger lines.

See Also:

  • Agilent M9036A product website
  • VI Tree and VI Descriptions
  • Programming examples
  • Related documentation


Selected backplane trigger bus to front panel SMB trigger connector

Trigger Source:
One of the eight PXI backplane trigger lines

Trigger Destination:
Front Panel SMB Trigger Connector (External

Notes:

  • You must select only one of the eight PXI backplane trigger bus lines (PXI_TRIG[0:7])
  • If the None enumeration is specified for one of the parameters, but not for the other parameter, then an Invalid Value error will be raised.


Front panel SMB trigger connector to selected backplane trigger bus

Trigger Source:
Front Panel SMB Trigger Connector (External)

Trigger Destination:
One of the eight PXI backplane trigger lines

Notes:

  • You must select only one of the eight PXI backplane trigger bus lines (PXI_TRIG[0:7])
  • If the None enumeration is specified for one of the parameters, but not for the other parameter, then an Invalid Value error will be raised.


Software generated trigger to selected backplane trigger bus

Trigger Source:
Software Generated

Trigger Destination:
One of the eight PXI backplane trigger lines

Notes:

  • The software trigger route configures the path for the software trigger state. In this mode, the trigger source is "software" and the destination is one of the PXI trigger lines. In general, you may want to set the software trigger state (high or low) before you configure the software trigger route. This way, the state will be immediately set when you establish the software trigger route.
  • If the None enumeration is specified for one of the parameters, but not for the other parameter, then an Invalid Value error will be raised.
  • A “software trigger” does not generate a trigger pulse. The Set Software Route Trigger State.vi defines a voltage level: True = 3.3V (asserted) and False = 0.0V (not asserted). To generate a pulse, you must toggle the state of the Set Software Route Trigger State.vi property; that is, set the property to one state, wait for the desired length of pulse, and then set the property to the opposite state.
  • You must select one of the eight PXI backplane trigger bus lines (PXI_TRIG[0:7])


Software generated trigger to selected backplane trigger bus and front panel SMB trigger connector

Trigger Source:
Software Generated

Trigger Destination:

One of the eight PXI backplane trigger lines and the front panel SMB trigger connector

Notes:

  • The software trigger route configures the path for the software trigger state. In this mode, the trigger source is "software" and the destination is one of the PXI trigger lines AND the front panel SMB trigger connector. In general, you may want to set the software trigger state (high or low) before you configure the software trigger route. This way, the state will be immediately set when you establish the software trigger route.
  • If the None enumeration is specified for one of the parameters, but not for the other parameter, then an Invalid Value error will be raised.
  • A “software trigger” does not generate a trigger pulse. The Set Software Route Trigger State.vi defines a voltage level: True = 3.3V (asserted) and False = 0.0V (not asserted). To generate a pulse, you must toggle the state of the Set Software Route Trigger State.vi property; that is, set the property to one state, wait for the desired length of pulse, and then set the property to the opposite state.
  • You must select one of the eight PXI backplane trigger bus lines (TTL TRIG[0:7]). The software-generated trigger signal will be active on the selected backplane trigger bus line and thus available to any PXI module installed in the chassis. You cannot select only the front panel SMB trigger connector as a trigger destination without selecting one of the eight PXI backplane trigger bus lines.


System Requirements

A Microsoft Windows operating system was installed at the factory. The latest version of Agilent IO Libraries was also installed along with any drivers necessary to operate the controller. The following table list the minimum system requirements for Agilent IO Libraries 16.1.

Operating System

Windows 7 (32- and 64-bit)

Processor Speed

1Ghz 32-bit (x86), 1GHz 64-bit (x64), no support for Itanium64

Available memory

1 GB minimum

Available hard disk space1

1.5 GB available hard disk space, includes:

  • 1GB available for Microsoft .NET Framework 3.5 SP12

  • 100MB for Agilent IO Libraries Suite

Video

Support for DirectX 9 graphics with 128MB graphics memory recommended (Super VGA graphics is supported)

Browser

Microsoft Internet Explorer 7 or greater

Footnotes:

1 Because of the installation procedure, less memory may be required for operation than is required for installation.

2 .NET Framework Runtime Components are installed by default with Windows Vista. Therefore, you may not need this amount of available disk space.

Note: You can download the latest version of Agilent IO Libraries Suite from: http:\\www.agilent.com\find\iosuite


Introduction - LabVIEW Reference

LabVIEW VI Name | Description
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Configure Route | This VI configures how a trigger signal is routed through the embedded system controller. This is done by specifying a routing configuration through the M9036A embedded system controller and a single PXI_TRIG backplane trigger line.
Error Message | Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.
GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.
GetAttributeViString | This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.
Get Enabled | Returns true if and only if the trigger routing subsystem of the embedded system controller is enabled. The Configure Route configures and enables this subsystem. The Reset Route and Reset disable this subsystem.
Get Software Route Trigger State | This VI reads the software route trigger state. The software route trigger state is used when ConfigureRoute has specified a configuration of "Software To Trigger Bus" or "Software To Trigger Bus And External".
Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Initialize With Options | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
IVI Error Converter | This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.
Query Route | This VI obtains the current trigger-routing status of the embedded system controller.
Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers).
Reset Route | This VI resets and disables the trigger routing subsystem of the embedded system controller. While in a reset state, the external trigger connection and the PXI_TRIG backplane lines are in a high-impedance state, and the SoftwareTriggerRouteState attribute has no effect.
Revision Query | Retrieves revision information from the instrument.
SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.
Set Software Route Trigger State | Sets the state of the software route trigger line. The software route trigger state is used when the ConfigureRoute has specified a configuration of "Software To Trigger Bus" or "Software To Trigger Bus And External".
VI Tree | The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


Get Enabled

Returns true if and only if the trigger routing subsystem of the embedded system controller is enabled. The Configure Route configures and enables this subsystem. The Reset Route and Reset disable this subsystem.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

Enabled

Returns true if and only if the trigger routing subsystem of the embedded system controller is enabled. The Configure Route configures and enables this subsystem. The Reset Route and Reset disable this subsystem.


Get Software Route Trigger State

This VI reads the software route trigger state. The software route trigger state is used when ConfigureRoute has specified a configuration of "Software To Trigger Bus" or "Software To Trigger Bus And External".

Get Software Route Trigger State

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

SoftwareRouteTriggerState

The state of the trigger line that has been routed for software control. A return value of True indicates the high level of 3.3 volts and False indicates the low level of 0 volts.


Reset Route

This VI resets and disables the trigger routing subsystem of the embedded system controller. While in a reset state, the external trigger connection and the PXI_TRIG backplane lines are in a high-impedance state, and the SoftwareTriggerRouteState attribute has no effect.

Remarks:

This VI disables the trigger routing subsystem by resetting the RouteConfiguraton to None and resetting the backplane trigger bus PXI_TRIG line to None.

Note that the trigger routing subsystem cannot be enabled or disabled independently of altering the trigger routing path and the selected backplane PXI_TRIG line.

Note that this function does not alter the state of the SoftwareRouteTriggerState attribute.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Set Software Route Trigger State

Sets the state of the software route trigger line. The software route trigger state is used when the ConfigureRoute has specified a configuration of "Software To Trigger Bus" or "Software To Trigger Bus And External".

Set Software Route Trigger State

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

SoftwareRouteTriggerState (Low)

Specifies the state (High = 3.3 volts, Low = 0.0 volts) of the associated backplane trigger bus line when the RouteConfiguration is set to "Software To Trigger Bus" or "Software To Trigger Bus and External". This state may be set, but will have no affect, when the RouteConfiguration is set to something other than the "Software To ..." settings.

This is a level-sensitive control. You may generate a pulse by setting this property to one state, waiting for the length of pulse desired, and then setting this property to the opposite state.

Note that the Reset Route does not alter this setting. However, the Reset method of this driver resets this setting to the power-on default of "Low".

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Configure Route

This VI configures how a trigger signal is routed through the embedded system controller. This is done by specifying a routing configuration through the M9036A embedded system controller and a single PXI_TRIG backplane trigger line.

Remarks:

If the None enumeration is specified for the RouteConfiguration parameter and the None enumeration is specified for the PXITriggerLine parameter, then this VI is equivalent to the ResetRoute, in which case this VI effectively disables the trigger routing subsystem.

If the None enumeration is specified for one of the parameters, but not for the other parameter, then an Invalid Value error will be raised.

The ResetRoute method resets this method's RouteConfiguration and PxiTrig parameters to their respective None enumerations, which effectively disables the triggering subsystem.

Note that the trigger routing subsystem cannot be enabled or disabled independently of altering the trigger routing path and the selected backplane PXI_TRIG line.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

RouteConfiguration (External To Trigger Bus)

Specifies the arrangement of interconnects between software-generated trigger, external (front panel) connection, and backplane connection.

The values have the following meanings:

External To Trigger Bus (0) : Drives the trigger signal from the external connector on the front-panel of the embedded system controller to the specified PXI trigger bus backplane line. In this state the SoftwareTrigger property has no effect.

Trigger Bus To External (1) : Drives the trigger signal from the specified PXI trigger bus backplane line to the external connector on the front-panel of the embedded system controller. In this state the SoftwareTrigger property has no effect.

Software To Trigger Bus (2) : Drives the current software trigger signal to the specified PXI trigger bus backplane line. In this state the external trigger connection is in a high-impedance state.

Software To Trigger Bus and External (3) : Drives the current software trigger signal to the specified PXI trigger bus backplane line and also drives the current software trigger signal to the external connector on the front-panel of the embedded system controller.

None (4) : Indicates the trigger routing function of the embedded system controller is in a reset (no connection) state. While in a reset state, the external trigger connection and the PXI_TRIG backplane lines are in a high-impedance state, and the SoftwareTrigger property has no effect.

If the None enumeration is specified for this parameter, but not for the PXITriggerLine parameter, then an Invalid Value error will be raised.

ci32

PXI Trigger Line (PXI_TRIG0)

Specifies the backplane trigger line (PXI_TRIG0 to PXI_TRIG7, or None) to be connected to the embedded system controller.

If the None enumeration is specified for this parameter, but not for the RouteConfiguration parameter, then an Invalid Value error will be raised.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Query Route

This VI obtains the current trigger-routing status of the embedded system controller.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

RouteConfiguration

Returns an integer that represents the current arrangement of interconnects between software-generated trigger, external (front panel) connection, and backplane connection.

The return values, and the routes they represent are as follows:

0 = External To Trigger Bus : Drives the trigger signal from the external connector on the front-panel of the embedded system controller to the specified PXI trigger bus backplane line. In this state the SoftwareTrigger property has no effect.

1 = Trigger Bus To External : Drives the trigger signal from the specified PXI trigger bus backplane line to the external connector on the front-panel of the embedded system controller. In this state the SoftwareTrigger property has no effect.

2 = Software To Trigger Bus : Drives the current software trigger signal to the specified PXI trigger bus backplane line. In this state the external trigger connection is in a high-impedance state.

3 = Software To Trigger Bus and External : Drives the current software trigger signal to the specified PXI trigger bus backplane line and also drives the current software trigger signal to the external connector on the front-panel of the embedded system controller.

4 = None : Indicates the trigger routing function of the embedded system controller is in a reset (no connection) state. While in a reset state, the external trigger connection and the PXI_TRIG backplane lines are in a high-impedance state, and the SoftwareTrigger property has no effect.

ii32

PxiTriggerLine

Returns the backplane trigger line, PXI_TRIG0 (return value = 0) to PXI_TRIG7 (return value = 7) that is connected to the embedded system controller. Note that if the trigger routing system is in a reset state, the None enumeration ( return value = 8) will be returned.


GetAttributeViBoolean

This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cu32

Attribute ID

Gets a Boolean attribute from the instrument driver.

The following Attributes are supported:

  • TRIGGERROUTING_ENABLED : Returns true if and only if the trigger routing subsystem of the embedded system controller is enabled. The ConfigureRoute configures and enables this subsystem. ResetRoute and Reset disable this subsystem.

  • SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

  • TRACE_ENABLED : If true, output trace log of all IVI driver calls to an XML file in the same directory as the application executable accessing the driver or as specified by the TraceName option (specified in option string of InitWithOptions). The log file may be viewed in your web browser. Beginning with Agilent IO Libraries Suite 16.0, driver trace messages may also be viewed with the IO Monitor utility. See IO Monitor help for details.

  • TRIGGERROUTING_SOFTWARE_ROUTE_TRIGGER_STATE : This read-write attribute maintains the state of the software route trigger state. The software route trigger state is used when SetRoute has specified a configuration of "RouteSoftwareToTriggerBus" or "RouteSoftwareToTriggerBusAndExternal".

Note that True specifies a high voltage (3.3 volts), while False specifies a low voltage (0 volts).This is a level-sensitive control. You may generate a pulse by setting this property to one state, waiting for the length of pulse desired, and then setting this property to the opposite state. Note that the ResetRoute method does not alter the state of this property. However, the Reset method of this driver resets this property to the power-on default of "False".

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


GetAttributeViInt32

This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cu32

Attribute ID

Gets an Int32 attribute from the instrument driver.

The following Attributes are supported:

  • TRIGGERROUTING_ROUTE_CONFIGURATION : Returns the current arrangement of interconnects between software-generated trigger, external connection, and backplane connection. Note that if the trigger routing system is in a reset state, the None enumeration will be returned.

  • TRIGGERROUTING_PXI_TRIG : Returns the backplane trigger line, PXI_TRIG0 (return value = 0) to PXI_TRIG7 (return value = 7), that is connected to the embedded system controller. Note that if the trigger routing system is in a reset state, the None enumeration ( return value = 8) will be returned.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


GetAttributeViString

This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

cu32

Attribute ID

Returns a string attribute from the instrument driver.

The following attributes are supported.

  • SPECIFIC_DRIVER_DESCRIPTION : Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NULL byte.

  • SPECIFIC_DRIVER_VENDOR : Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NULL byte.

  • SPECIFIC_DRIVER_REVISION : Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NULL byte.

  • LOGICAL_NAME : Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

  • IO_RESOURCE_DESCRIPTOR : The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize VI.

  • DRIVER_SETUP : The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

  • SUPPORTED_INSTRUMENT_MODELS : A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer.

  • INSTRUMENT_FIRMWARE_REVISION : The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

  • INSTRUMENT_MANUFACTURER : The name of the manufacturer reported by the physical instrument.

  • INSTRUMENT_MODEL : The model number or name reported by the physical instrument.

  • SYSTEM_SERIAL_NUMBER : Returns the module serial number.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


SetAttributeViBoolean

This routine is used to access low-level settings of the instrument. See the AttributeID parameter for a link to all properties of the instrument.

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

AttributeValue (Off)

The value to which to set the property.

cu32

Attribute ID

Sets a Boolean attribute from the instrument driver.

The following Attributes are supported:

  • SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

  • TRACE_ENABLED : If true, output trace log of all IVI driver calls to an XML file in the same directory as the application executable accessing the driver or as specified by the TraceName option (specified in option string of InitWithOptions). The log file may be viewed in your web browser. Beginning with Agilent IO Libraries Suite 16.0, driver trace messages may also be viewed with the IO Monitor utility. See IO Monitor help for details.

  • TRIGGERROUTING_SOFTWARE_ROUTE_TRIGGER_STATE : This read-write attribute maintains the state of the software route trigger state. The software route trigger state is used when ConfigureRoute has specified a configuration of "Software To Trigger Bus" or "Software To Trigger Bus And External".

Note that True specifies a high voltage (3.3 volts), while False specifies a low voltage (0 volts).This is a level-sensitive control. You may generate a pulse by setting this property to one state, waiting for the length of pulse desired, and then setting this property to the opposite state. Note that the ResetRoute does not alter the state of this property. However, the Reset of this driver resets this property to the power-on default of "False".

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Error Message

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ci32

Error Code

Instrument driver status code.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

Error Message

Instrument driver error message.


IVI Error Converter

This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

IVI Error Converter

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

IVI error code (0)

Error code returned from an IVI instrument driver operation.

cu32

instrument handle

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iu32

instrument handle out

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None


Reset

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers).

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Revision Query

Retrieves revision information from the instrument.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

istr

instrument driver revision

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision property. Refer to the Specific Driver Revision property for more information.

istr

firmware revision

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision property. Refer to the Instrument Firmware Revision property for more information.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

resource string

A string that specifies the instrument to connect to. For the AgM9036 Trigger driver, this string must specify "Controller" (case insensitive) or an empty string.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Initialize With Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Initialize With Options

cstr

resource name

A string that specifies the instrument to connect to. For the AgM9036 Trigger driver, this string must specify "Controller" (case insensitive) or an empty string.

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cstr

option string

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameter is "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


Attributes

The following table provides an alphabetical listing of the attributes used in this driver.

Attribute | Used in | Description
DRIVER_SETUP | GetAttributeViString | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
INSTRUMENT_FIRMWARE_REVISION | GetAttributeViString | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
INSTRUMENT_MANUFACTURER | GetAttributeViString | The name of the manufacturer reported by the physical instrument.
INSTRUMENT_MODEL | GetAttributeViString | The model number or name reported by the physical instrument.
IO_RESOURCE_DESCRIPTOR | GetAttributeViString | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize VI.
LOGICAL_NAME | GetAttributeViString | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
SIMULATE | GetAttributeViBoolean, GetAttributeViString, Initialize With Options, SetAttributeViBoolean | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
SPECIFIC_DRIVER_DESCRIPTION | GetAttributeViString | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NULL byte.
SPECIFIC_DRIVER_REVISION | GetAttributeViString | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NULL byte.
SPECIFIC_DRIVER_VENDOR | GetAttributeViString | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NULL byte.
SUPPORTED_INSTRUMENT_MODELS | GetAttributeViString | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer.
SYSTEM_SERIAL_NUMBER | GetAttributeViString | Returns the module serial number.
TRACE_ENABLED | GetAttributeViBoolean, SetAttributeViBoolean | If true, output trace log of all IVI driver calls to an XML file in the same directory as the application executable accessing the driver or as specified by the TraceName option (specified in option string of InitWithOptions). The log file may be viewed in your web browser. Beginning with Agilent IO Libraries Suite 16.0, driver trace messages may also be viewed with the IO Monitor utility. See IO Monitor help for details.
TRIGGERROUTING_ENABLED | GetAttributeViBoolean | Returns true if and only if the trigger routing subsystem of the embedded system controller is enabled. The ConfigureRoute configures and enables this subsystem. ResetRoute and Reset disable this subsystem.
TRIGGERROUTING_PXI_TRIG | GetAttributeViInt32 | Returns the backplane trigger line, PXI_TRIG0 (return value = 0) to PXI_TRIG7 (return value = 7), that is connected to the embedded system controller. Note that if the trigger routing system is in a reset state, the None enumeration ( return value = 8) will be returned.
TRIGGERROUTING_ROUTE_CONFIGURATION | GetAttributeViInt32 | Returns the current arrangement of interconnects between software-generated trigger, external connection, and backplane connection. Note that if the trigger routing system is in a reset state, the None enumeration will be returned.
TRIGGERROUTING_SOFTWARE_ROUTE_TRIGGER_STATE | GetAttributeViBoolean, SetAttributeViBoolean | This read-write attribute maintains the state of the software route trigger state. The software route trigger state is used when SetRoute has specified a configuration of "RouteSoftwareToTriggerBus" or "RouteSoftwareToTriggerBusAndExternal".


Programming Examples

The following example VIs are provided to demonstrate the basic features of the M9036A Trigger Subsystem. Each example VI has a front panel you can use to exercise the underlying VI functions.

  • PulseTrigger
  • RouteTrigger


Agilent M9036 - PulseTrigger

This example initializes the instrument and reads a few Identity interface properties. Next, a "Software" trigger route is connected to the PXI Trigger Line specified, and that line is pulsed by software commands.

See the block diagram window for the detailed steps shown below:

Step1: The application is initialized.

Step2: Get instrument information for display on front panel

Step3: Drive the software trigger route to a low state ( 0.0 V) BEFORE connecting the route

Step4: Connect the route that allows software control of the trigger state of the selected PXI Trigger Line

Step5: Drive the selected PXI Trigger line to high state ( 3.3 V)

Step6: Drive the selected PXI Trigger line to low state ( 0.0 V)

Step7: Close the session to the instrument

Step8: Display any errors

Agilent M9036 - PulseTrigger

The following screen shows the user interface:


Agilent M9036 - RouteTrigger

This example shows various trigger routing configurations. The steps are shown and commented in the block diagram. They are as follows:

Step 1: The application is initialized.

Step 2: Set trigger route to have source of front panel External (SMB) connector and destination of PXI Trigger line 3.

Step 3: Change route to have source of PXI Trigger line 4 and destination of front panel External (SMB) connector.

Step 4: BEFORE selecting the software route, set the state (level) on that route to be True ( high state of 3.3. V).

Step 5: Select the software controlled route to be PXI Trigger line 5, which will now be high (true) due to previous step.

Step 6: Drive the selected PXI Trigger line (5) to the false state ( low level of 0.0 V).

Step 7: Drive the line to the True state ( high level of 3.3 V).

Step 8: Select the software controlled route to driver PXI Trigger line 6 *and* the External connector.

Step 9: Change the level on the software controlled Trigger line and External connector to the False state (low level of 0.0 V).

Step 10: Reset the route, this will set source of None and destination of None.

Step 11: Close the session to the instrument

Step 12: Display any errors

Agilent M9036 - RouteTrigger

The following screen shows the user interface:

Oscilloscope trace example

The following oscilloscope trace illustrates this example program. This trace was generated with the oscilloscope connected to the front panel SMB connector. Note that individual backplane trigger lines will change states while the program runs but are not indicated on the oscilloscope trace. The white lines and numbers on the trace are approximate and correspond to the step numbers above and below.

The trace begins with the M9036A driving a low out the external, front panel SMB connector (due to a prior state setting).

Step 1: When the program calls Initialize with Options, the external (SMB) trigger line (and all of the backplane PXI trigger lines becomes tri-stated), therefore, it floats to approximately 3.0 volts.

Step 2: A Configure Route call configures the trigger route to connect the external SMB to PXI Trigger Line 3 [External To Trigger Bus, PXI_TRIG3]. With the SMB as an input, the SMB line driver in the M9036A remains tri-stated. PXI Trigger Line 3 also floats.

Step 3: A Configure Route call changes the trigger route to connect the external SMB connector to PXI Trigger Line 4 [Trigger Bus to External, PXI_TRIG4]. The external SMB remains tri-stated since it is still not driven by the Software Trigger State. PXI Trigger Line 4 also floats.

Step 4: Sets the Software Route Trigger State to High (3.3 V). Both the external SMB and Trigger Line 4 are driven high.

Step 5: Then the program makes a call to change the route setting to Software to PXI Trigger Line 5 [Software To Trigger Bus, PXI_TRIG5]. Since the software route no longer includes the external SMB trigger line, it becomes tri-stated. Trigger Line 4 is now tri-stated and Trigger Line 5 is driven high.

Step 6: A call sets the Software Trigger State to Low (0 V).Trigger Line 5 is driven low but the signal out of the external SMB trigger connector remains tri-stated.

Step 7: Sets the Software Trigger State to High (3.3 V). Trigger Line 5 is driven high but there is still no effect on the external SMB line.

Step 8: Makes a call to change the route to connect PXI Trigger Line 6 and the external SMB connector [Software To Trigger Bus And External, PXI_TRIG6]. Now, both the SMB trigger line and PXI Trigger Line 6 are driven high because the Software Trigger State is set high.

Step 9: Makes another call to set the Software Route Trigger State to Low (0 V) where the external SMB trigger line is driven low.

Step 10: Makes a call to Reset Route. All trigger lines, including the front panel SMB Trigger Line, become tri-stated.

Step 11: Closes the program session.


Related Documentation

The following are user documentation related to the Agilent M9036A PXIe Embedded Controller:

  • M9036A PXIe Embedded Controller Startup Guide: Refer to the M9036A Product Information CD or check on the web for the latest version.
  • M9036A PXIe Embedded Controller User Guide: Refer to the M9036A Product Information CD or check on the web for the latest version.
  • M9036A PXIe Embedded Controller Data Sheet See the M9036A Product Information CD or check on the web for the latest data sheet.

General Driver Information

  • SoftFront Panel Interface help: For Start menu access, select: Start > All Programs > Agilent > M9036 PXIe Embedded Controller > M9036 Help. Or, see the M9036A Product Information CD or check on the web for the latest driver.

  • IVI C and IVI COM Driver information: For the IVI driver, program examples, etc.: C:\ProgramFiles\IVI Foundation\IVI\Drivers\AgM9036

  • Web information on the Agilent M9036A PXIe Embedded Controller: www.agilent.com\find\M9036A.


Glossary

My Term
My definition